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1. Product Introduction 

The MVT series Valve terminal node adopts the integrated design 

of bus interface, IO-Link expansion port and power supply, and is 

installed on the bus electrical interface. At present, the main products 

are IO-Link slave station, multi-protocol slave station and multi-

protocol master station. Compatible bus protocols include Profinet, 

Ethernet/IP and CC-LINK IE Field BASIC. 

The connection system of the MVT series is designed with M12 

sockets for easy power supply and quick bus plugging. 

MVT series master valve terminal node is suitable for PNP sensors, 

travel switches, dry contact signal acquisition, PNP load output and 

other application scenarios, providing cost-effective valve terminal 

product solutions for automotive, photovoltaic, logistics and other 

industries. 

2. Version change history 

Date of revision Release version content of change  

2024-9 V1.0 The first edition of the 

manual is released 

   

   

3. About manual acquisition 

This manual is not shipped with the product, and if you need to 

obtain an electronic PDF file, you can obtain it in the following ways: 

 Log in to the official website of Elco (www.elco-holding.com.cn), 

search for keywords and download. 

 Use WeChat to search and follow the official public account of " Elco 

Automation" to get the product matching manual. 

 Contact the sales engineer of Elco Automation in your area to get the 

latest manual materials. 
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4. Warranty Statement 

Under normal use, if the product fails or is damaged, Elco 

Automation is responsible for the 18-month warranty (from the date of 

delivery, subject to the date of delivery, and the contract agreement 

shall be implemented in accordance with the agreement). More than 18 

months, the repair fee will be charged.。 

Within 18 months, the repair fee will be charged for product 

damage caused by the following conditions. 

 Failure to operate this product as specified in the manual, resulting 

in damage to the product. 

 Fire, flood, abnormal voltage, product damage. 

 Use of this product for non-normal functions, resulting in damage to 

the product. 

 Product damage caused by exceeding the specified scope of use of 

the product. 

 Secondary damage to the product caused by force majeure (natural 

disasters, earthquakes, lightning strikes). 

The service fee is calculated according to the unified standard of 

Elco, and if there is a contract, it will be handled according to the 

principle of contract priority. 
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5. Introduction to the MVT series of modules 

5.1. Appearance and function introduction 

5.1.1. MVT-C-LK appearance and function introduction 

 

 

ordinal name function state 

1 Module fixing clips 

 
Module fixing 

holes 

It is used to fix the valve 

terminal node on the 

valve terminal interface 

- 

2 Power connector 

 

1 US 24V+ - 

2 UA 24V+ - 

3 US 0V - 

4 C/Q - 

5 UA 0V - 

3 Diagnostic light 

 

US System power status  

LK Communication status  

UA Auxiliary power state  
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5.1.2. MVT-C-EN appearance and function introduction 

 

ordinal name function state 

1 Module fixing clips 

 
Module fixing 

holes 

It is used to fix the valve 

terminal node on the 

valve terminal interface 

- 

2 Power connector 

 

1 System power Us+ - 

2 Auxiliary power Ua- - 

3 System power Us- - 

4 Auxiliary power Ua+ - 

5 PE - 

3 Diagnostic light 

 

Us System power status  

Ua Auxiliary power status  

NET 
Bus communication 

failure 
 

MOD System Fault Indication  
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1 

2 

3 

4 

5 

6 

 

5.1.3. MVT-E-EN appearance and function introduction 

 

Lk1/Lk2 
Network port connection 

status 
 

Act1/Act2 Network traffic status  

4 Bus interface   

 

1 Transmitter TD+  

2 Receiver RD+  

3 Transmitter TD-  

4 Receiver RD-  

5 control panel DIP switch, reset button  

ordinal name function state 

1 Module fixing clips 

 
Module fixing 

holes 

It is used to fix the valve 

terminal node on the 

valve terminal interface 

- 

2 Power connector 

 
1 System power Us+ - 

2 Auxiliary power Ua- - 
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5.2. Module Specifications          
Ordering data 

Type MVT-C-LK MVT-C-EN MVT-E-EN 

Description 

Class-B Supports multiple 

bus protocols 

Supports multiple bus 

protocols, 

with IO-Link master

（2*Class-A) 

Matching Festo valve 

Terminals 

VTUG series 

Field bus 

Protocol IO-Link 
Profinet,CC-Link 

IE,Ethernet/IP 

Profinet,CC-Link 

IE,Ethernet/IP 

Field bus, connection 

system  

Class-B:1*M12,A-

CODE,5pin,Male 

 2*M12,D-

CODE,4pin，Female 

2* M12,D-

CODE,4pin,Female 

3 System power Us- - 

4 Auxiliary power Ua+ - 

5 PE - 

3 Diagnostic light 

 

Us System power status  

Ua Auxiliary power status  

NET 
Bus communication 

failure 
 

MOD System Fault Indication  

Lk1/Lk2 
Network port connection 

status 
 

Act1/Act2 Network traffic status  

CH1/CH2 
port1/port2 Status 

indication 
 

4 Bus interface   

 1 Transmitter TD+  

 2 Receiver RD+  

 3 Transmitter TD-  

 4 Receiver RD-  

5 control panel DIP switch, reset button  

6 Signal interface   

 1 US 24V+  

 2 I/O  

 3 US 0V  

 4 C/Q  

 5 PE  
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IO-Link Expansion 

port 
—— —— 

2*M12,A-

CODE,5pin,Female 

Electrical isolation  yes 

Transmission rate —— 100Mbps 100Mbps 

Max. address 

volume, inputs 
8 Byte 8 Byte 106 Byte 

Max. address 

volume, outputs 
6 Byte 6 Byte 74 Byte 

Power supply 

Nominal operating 

voltage DC 

24V 

Operational voltage 

range DC 

18-30V 

System Max. power 

supply 

1A 4A 4A 

Valve Max. power 

supply 
2A 2A 2A 

Intern power 

consumption 

nominal operating 

voltage  

Less than 100 mA Less than 200 mA Less than 200 mA 

Power supply, 

connection system 

The bus interface 

includes power supply 

M12*1，L-CODE，

5pin，Male 

M12*1，L-CODE，5pin，

Male 

Technical data 

Expansion port type —— —— 2*Class-A 

Max. number of 

solenoid coils 
48 

Maximum number 

of valve positions 
24 

 Power supply, 

inputs（pin1&pin3） 
—— —— IO-Link port Max 1.6A 

Input signal type —— —— 

PNP type sensor,Travel 

switch,dry contact(SIO 

mode) 

 Power supply, 

outputs

（pin2&pin3） 

—— —— Max 2A  

Output signal type —— —— PNP type loads 

Diagnosis 
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Communication 

status 
Communication failure alarm 

Power supply 

detection 
Low voltage alarm 

System diagnostics System failure alarm 

General parameters 

Dimensions 42*91*40mm 

Type of mounting On electrical interface 

Operation 

temperature 
-5℃-60℃ 

Storage temperature -20℃-70℃ 

protection class IP67 

5.3. Introduction to the DIP function 

DIP switch Instructions note 

0 Ethernet/IP DHCP mode 

When switching protocols: 

the PT light stays on 

continuously, and the 

PORT red light stays on 

continuously. 

1~2 IP mode set by the Ethernet/IP webserver 

3 Profinet protocol 

4 CCLink default mode 

5~6 IP mode set by the CCLink webserver 

9 Clearing Device Configuration (IP Configuration) 
The PORT yellow light 

flashes alternately 

other Error status 
The PT light is always 

on 

Function selection is performed by adjusting the DIP switch shown 

in the diagram. 

After dialing the DIP to the corresponding digit, power off and 

restart (or dial the DIP to the corresponding digit after the power off, 

and then power on), when switching the protocol, the PT light above 

the DIP switch will be on, and the PORT red light will be on. 
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5.4. Module Dimensions 

 

6. Mechanical installation and disassembly of products 

6.1. Installation location 
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The installation position is as shown in the figure above, the valve 

terminal node is installed horizontally at the electrical interface of the 

valve terminal gas circuit board, and the connector and control panel 

must be facing upward. 

 Warn! 

 Only professional maintenance personnel who have received 

relevant training in electrical equipment and have sufficient 

electrical knowledge can install this product; 

 When disassembling and disassembling modules, it is necessary 

to disconnect all external power supplies used by the system 

before performing the operation. If the power supply is not 

completely disconnected, it may lead to electric shock or 

module failure and malfunction; 

 Do not use MVT in the following places: places with dust, oil 

smoke, conductive dust, corrosive gases, and flammable gases; 

Exposure to high temperatures, condensation, wind and rain; 

Occasions with vibration and shock. Electric shock, fire, 

mishandling can also cause damage and deterioration of the 

product; 

6.2. MVT product installation 

The installation of MVT products can be carried out in the 

following steps: 
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6.3.  Valve terminal node disassembly 

Use a flathead screwdriver or similar tool to unscrew the mounting 

screws counterclockwise and pull the node module out away from the 

valve terminal manifold plate. 

 

  

 Warn! 

 To install, align the valve terminal node with the electrical 

interface and insert the pin in the direction indicated by the 

arrow； 

 Tighten the mounting bolts without excessive force to 

prevent damage to the product; 

 Warn! 

 The mechanical installation and disassembly of the module 

need to be operated by qualified professional mechanical 

personnel, and attention should be paid to the correct wearing and 

use of labor protection equipment. 

STEP1：Buckle the valve terminal 

node at the electrical interface of 

the valve terminal; 

STEP2 ： Use a screwdriver to 

secure the screws on the valve 

terminal nodes. 
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7. Interface definition of valve terminal nodes of the MVT 

series 

7.1. MVT-C-LK interface definition 

     Bus port 

7.2. MVT-C-EN interface definition 

    Power port 

   Bus port 

7.3. MVT-E-EN interface definition 
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   Power port 

 

 

   Bus port 

 

 

   Signal port 
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8. Electrical installation and wiring of the product 

8.1. Cable specifications 

8.1.1. Communication cables 

Ethernet bus communication uses shielded network cable for 

network data transmission, without short circuit, dislocation and poor 

contact; The length of the cable between the devices cannot exceed 

100m, and the signal will be attenuated and the normal communication 

will be affected. The following types of communication cables are 

recommended: 
project specification 

Cable type Elastic crossover cable, S-FTP, Category 5 wire 

Criteria met 
EIA/TIA568A，EN50173，ISO/IEC11801 EIA/TI 
Abulletin TSB，EIA/TIA SB40‑A&TSB36  

Traverse 
section 

AWG26 

Wire type Twisted pair 

Number of 
cable pairs 

4 

The pre-injection connector has better communication stability and 

construction convenience, and the pre-injection connector of the Elco 

brand can provide personalized customization of cable material and 

length under the condition of meeting the requirements of 

communication technology, and the following Elco Ethernet connectors 

are available: 
type description 

E16DA4002M020 RJ45-M12 Double-ended Pre-Injection Ethernet Connector, Pin Straight,  

D-CODE, 4-PIN, Cat5e, PVC, cord length 2 meters, fixed installation 

E11D04002M020 M12-M12 Double-ended Pre-Injection Ethernet connector, straight end 

ended, D-CODE, 4-PIN, Cat5e, PVC, cable length 2 m, fixed installation 

E16DA4004M020 
RJ45-M12 Double-ended Pre-Injection Ethernet Connector, Pin Straight,  

D-CODE, 4-PIN, Cat5e, PUR, cord length 2 m, tow chain suitable 
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E11D04004M020 
M12-M12 Double-ended Pre-Injection Ethernet connector, straight head, 

D-CODE, 4-PIN, Cat5e, PUR, cable length 2 m, tow chain suitable 

 

  

More Ethernet connector selection please refer to Elco 

"Connection system Comprehensive sample". 
 

8.1.2. Power and signal lines 

Power & Signal Wiring Requirements: 

The MVT-C-EN and MVT-E-EN power supplies are M12, L-CODE, 5-

pin pin connectors, and the MVT-E-EN expansion ports are M12, A-

CODE, 5-pin pin connectors. 

IO-Link cables: 

According to the IO-Link protocol, point-to-point communication 

is used between the master station and the sub-station, and an 

extended distance of 20 meters can be achieved with the help of 

ordinary unshielded industrial cables (such as sensor cables). 

According to the IO-Link protocol standard, a normal three-core 

cable can meet the communication requirements, while the remaining 

WARN! 

 Disconnect all power connections before wiring 

construction! 

 Copper wire only! 

 To ensure safety, ensure that the grounding terminal of 

the module is securely connected to the ground! 

 Wiring work must be operated by authorized electrical 

personnel to ensure construction safety! 

 Improper cables may cause serious equipment damage 

or personal injury! 

 Connect cables by referring to this manual or the wiring 

diagram printed on the side of the module. Incorrect 

wiring may cause module damage or personal injury! 
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four- or five-core cables are used for specific functions. The IO-Link 

valve terminal nodes of the MVT series use the IO-Link interface of the 

Class-B type. 

For Class-B IO-Link interfaces, since all five pins are defined, the IO-

Link hub in this form should be connected to the master with a five-

core cable. 
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9. Input and output data structures 

9.1.  MVT-C-LK process data structure 

The occupied Input is 8 bytes, The occupied output is 6 bytes. 

BYTE 0 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 0.7 Q 0.6 Q 0.5 Q 0.4 Q 0.3 Q 0.2 Q 0.1 Q 0.0 

descript

ion 

Valve_4

_12 

Valve_

4_14 

Valve_

3_12 

Valve_

3_14 

Valve_

2_12 

Valve_

2_14 

Valve_

1_12 

Valve_1

_14 

BYTE 1 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 1.7 Q 1.6 Q 1.5 Q 1.4 Q 1.3 Q 1.2 Q 1.1 Q 1.0 

descript

ion 

Valve_8

_12 

Valve_

8_14 

Valve_

7_12 

Valve_

7_14 

Valve_

6_12 

Valve_

6_14 

Valve_

5_12 

Valve_5

_14 

BYTE 2 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 2.7 Q 2.6 Q 2.5 Q 2.4 Q 2.3 Q 2.2 Q 2.1 Q 2.0 

descript

ion 

Valve_1

2_12 

Valve_

12_14 

Valve_

11_12 

Valve_

11_14 

Valve_

10_12 

Valve_

10_14 

Valve_

9_12 

Valve_9

_14 

BYTE 3 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 3.7 Q 3.6 Q 3.5 Q 3.4 Q 3.3 Q 3.2 Q 3.1 Q 3.0 

descript

ion 

Valve_1

6_12 

Valve_

16_14 

Valve_

15_12 

Valve_

15_14 

Valve_

14_12 

Valve_

14_14 

Valve_

13_12 

Valve_1

3_14 

BYTE 4 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 4.7 Q 4.6 Q 4.5 Q 4.4 Q 4.3 Q 4.2 Q 4.1 Q 4.0 

descript

ion 

Valve_2

0_12 

Valve_

20_14 

Valve_

19_12 

Valve_

19_14 

Valve_

18_12 

Valve_

18_14 

Valve_

17_12 

Valve_1

7_14 

BYTE 5 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 5.7 Q 5.6 Q 5.5 Q 5.4 Q 5.3 Q 5.2 Q 5.1 Q 5.0 

descript

ion 

Valve_2

4_12 

Valve_

24_14 

Valve_

23_12 

Valve_

23_14 

Valve_

22_12 

Valve_

22_14 

Valve_

21_12 

Valve_2

1_14 

Input Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

BYTE 0 Status 8 Status 7 Status 6 Status 5 Status 4 Status 3 Status 2 Status 1 

BYTE 1 Status 16 Status 15 Status 14 Status 13 Status 12 Status 11 Status 10 Status 9 

BYTE 2 Status 24 Status 23 Status 22 Status 21 Status 20 Status 19 Status 18 Status 17 

BYTE 3 Status 32 Status 31 Status 30 Status 29 Status 28 Status 27 Status 26 Status 25 

BYTE 4 Status 40 Status 39 Status 38 Status 37 Status 36 Status 35 Status 34 Status 33 

BYTE 5 Status 48 Status 47 Status 46 Status 45 Status 44 Status 43 Status 42 Status 41 

BYTE 6 Reserved 

BYTE 7 Uaux 

Overvol

tage 

Uaux 

Underv

oltage 

Usys 

Overvo

ltage 

Usys 

Underv

oltage 

Uaux 

Error 

  Reserved 
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9.2. MVT-C-EN process data structure 

The occupied Input is 8 bytes, The occupied output is 6 bytes. 

BYTE 0 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 0.7 Q 0.6 Q 0.5 Q 0.4 Q 0.3 Q 0.2 Q 0.1 Q 0.0 

descript

ion 

Valve_4

_12 

Valve_

4_14 

Valve_

3_12 

Valve_

3_14 

Valve_

2_12 

Valve_

2_14 

Valve_

1_12 

Valve_1

_14 

BYTE 1 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 1.7 Q 1.6 Q 1.5 Q 1.4 Q 1.3 Q 1.2 Q 1.1 Q 1.0 

descript

ion 

Valve_8

_12 

Valve_

8_14 

Valve_

7_12 

Valve_

7_14 

Valve_

6_12 

Valve_

6_14 

Valve_

5_12 

Valve_5

_14 

BYTE 2 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 2.7 Q 2.6 Q 2.5 Q 2.4 Q 2.3 Q 2.2 Q 2.1 Q 2.0 

descript

ion 

Valve_1

2_12 

Valve_

12_14 

Valve_

11_12 

Valve_

11_14 

Valve_

10_12 

Valve_

10_14 

Valve_

9_12 

Valve_9

_14 

BYTE 3 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 3.7 Q 3.6 Q 3.5 Q 3.4 Q 3.3 Q 3.2 Q 3.1 Q 3.0 

descript

ion 

Valve_1

6_12 

Valve_

16_14 

Valve_

15_12 

Valve_

15_14 

Valve_

14_12 

Valve_

14_14 

Valve_

13_12 

Valve_1

3_14 

BYTE 4 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 4.7 Q 4.6 Q 4.5 Q 4.4 Q 4.3 Q 4.2 Q 4.1 Q 4.0 

descript

ion 

Valve_2

0_12 

Valve_

20_14 

Valve_

19_12 

Valve_

19_14 

Valve_

18_12 

Valve_

18_14 

Valve_

17_12 

Valve_1

7_14 

BYTE 5 Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

address Q 5.7 Q 5.6 Q 5.5 Q 5.4 Q 5.3 Q 5.2 Q 5.1 Q 5.0 

descript

ion 

Valve_2

4_12 

Valve_

24_14 

Valve_

23_12 

Valve_

23_14 

Valve_

22_12 

Valve_

22_14 

Valve_

21_12 

Valve_2

1_14 

Input Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 

BYTE 0 Status 8 Status 7 Status 6 Status 5 Status 4 Status 3 Status 2 Status 1 

BYTE 1 Status 16 Status 15 Status 14 Status 13 Status 12 Status 11 Status 10 Status 9 

BYTE 2 Status 24 Status 23 Status 22 Status 21 Status 20 Status 19 Status 18 Status 17 

BYTE 3 Status 32 Status 31 Status 30 Status 29 Status 28 Status 27 Status 26 Status 25 

BYTE 4 Status 40 Status 39 Status 38 Status 37 Status 36 Status 35 Status 34 Status 33 

BYTE 5 Status 48 Status 47 Status 46 Status 45 Status 44 Status 43 Status 42 Status 41 

BYTE 6 Reserved 

BYTE 7 Uaux 

Overvol

tage 

Uaux 

Underv

oltage 

Usys 

Overvo

ltage 

Usys 

Underv

oltage 

Uaux 

Error 

  Reserved 
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9.3. MVT-E-EN process data structure 

The maximum input is 106 bytes, and the output is 74 bytes 

Input Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 description 

IB0 Status 8 Status 7 Status 6 Status 5 Status 4 Status 3 Status 2 Status 1 Valve 

Terminal 

Status 

IB1 Status 16 Status 15 Status 14 Status 13 Status 12 Status 11 Status 10 Status 9 

IB2 Status 24 Status 23 Status 22 Status 21 Status 20 Status 19 Status 18 Status 17 

IB3 Status 32 Status 31 Status 30 Status 29 Status 28 Status 27 Status 26 Status 25 

IB4 Status 40 Status 39 Status 38 Status 37 Status 36 Status 35 Status 34 Status 33 

IB5 Status 48 Status 47 Status 46 Status 45 Status 44 Status 43 Status 42 Status 41 

IB6     Port2 Pin2 Port2 Pin4 Port1 Pin2 Port1 Pin4 IO Signal 

IB7 Uaux 

Overvol

tage 

Uaux 

Undervo

ltage 

Usys 

Overvol

tage 

Usys 

Undervo

ltage 

Uaux 

Error 
  Reserved 

Master 

Power 

Status 

IB8 Secondary 

Supply 

Voltage 

Fault 

Device 

Diagnose 

IO-Link 

Device 

Validation 

Error 

Communic

ation 

Lost 

 
Pin2 

Overload 

Pin4 

Overload 

Pin1 

Power 

Short 

Port1 

IOLINK 

Status 

IB9 Secondary 

Supply 

Voltage 

Fault 

Device 

Diagnose 

IO-Link 

Device 

Validation 

Error 

Communic

ation 

Lost 

 
Pin2 

Overload 

Pin4 

Overload 

Pin1 

Power 

Short 

Port2 

IOLINK 

Status 

IB10~I

B41 

IOL Port1 Input 

IB42 IOL Port1 Status  IOL:Port in IO-Link mode   DC:Device connected  

      DC IOL 

IB43 IOL Port1 Error   VF: Validation failed   SC: IO-Link short-circuit 

DF: Data storage validation failed   PDI: Process data invalid 

 

SC     PDI DF VF 

IB44~I

B45 

IOL Port1 Vendor ID MSB 

IB46~I

B48 

IOL Port1 Device ID MSB 

IB49 IOL Port1 EventQualifier1 
 

Mode Type     

IB50~I

B51 

IOL Port1 EventCode1 

IB52 IOL Port1 EventQualifier2 

Mode Type     
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IB53~I

B54 

IOL Port1 EventCode2 

IB55 IOL Port1 EventQualifier3 

Mode Type     

IB56~I

B57 

IOL Port1 EventCode3 

Mode: 

0: reserved;       1: Single event; 

2: Event outgoing; 3: Event incoming 

Type: 

0: reserved;       1: Message; 

2: Warning;        3: Error 

EventCode: MSB 

IB58~I

B89 

IOL Port2 Input 

IB90 IOL Port2 Status Ref 

Port1 IB91 IOL Port2 Error 

IB92~I

B93 

IOL Port2 Vendor ID 

IB94~I

B96 

IOL Port2 Device ID 

IB97 IOL Port2 EventQualifier1 

IB98~I

B99 

IOL Port2 EventCode1 

IB100 IOL Port2 EventQualifier2 

IB101~

IB102 

IOL Port2 EventCode2 

IB103 IOL Port2 EventQualifier3 

1B104~

IB105 

IOL Port2 EventCode3 

Output Bit 7 Bit 6 Bit 5 Bit 4 Bit 3 Bit 2 Bit 1 Bit 0 description 

QB0 Output 8 Output 7 Output 6 Output 5 Output 4 Output 3 Output 2 Output 1 Value 

Terminal 

Output 

QB1 Output 16 Output 15 Output 14 Output 13 Output 12 Output 11 Output 10 Output 9 

QB2 Output 24 Output 23 Output 22 Output 21 Output 20 Output 19 Output 18 Output 17 

QB3 Output 32 Output 31 Output 30 Output 29 Output 28 Output 27 Output 26 Output 25 

QB4 Output 40 Output 39 Output 38 Output 37 Output 36 Output 35 Output 34 Output 33 

QB5 Output 48 Output 47 Output 46 Output 45 Output 44 Output 43 Output 42 Output 41 

QB6     Port2 Pin2  Port1 Pin2  IO Signal 

QB7 Reserved  
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QB8 
       Diagnose 

Disable 

Port1 

Control 

QB9 
       Diagnose 

Disable 

Port2 

Control 

QB10~Q

B41 

IOL Port1 Output  

QB42~Q

B73 

IOL Port2 Output  

 

You can select different bytes according to your needs, and the 

process data displayed above is the maximum value, with 106 bytes for 

input and 74 bytes for output. 

9.4. Disconnection output control description 

Disconnection 

output 

control 

0- Clear Output; 

1- All outputs high; 

2- Hold the output; 

 

9.5. Description of channel diagnostic bits 

diagnosis 

byte 
BIT7 BIT6 BIT5 BIT4 BIT3 BIT2 BIT1 BIT0 

Byte0 Diag CH8 Diag CH7 Diag CH6 Diag CH5 Diag CH4 Diag CH3 Diag CH2 Diag CH1 

Byte1 Diag CH16 Diag CH15 Diag CH14 Diag CH13 Diag CH11 Diag CH11 Diag CH10 Diag CH9 

Byte2 Diag CH24 Diag CH23 Diag CH22 Diag CH21 Diag CH20 Diag CH19 Diag CH18 Diag CH17 

Byte3 Diag CH32 Diag CH31 Diag CH30 Diag CH29 Diag CH28 Diag CH27 Diag CH26 Diag CH25 

Byte4 Diag CH40 Diag CH39 Diag CH38 Diag CH37 Diag CH36 Diag CH35 Diag CH34 Diag CH33 

Byte5 Diag CH48 Diag CH47 Diag CH46 Diag CH45 Diag CH44 Diag CH43 Diag CH42 Diag CH41 
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10. Configuration and commissioning 

10.1. Debugging in the Siemens PORTAL environment 

10.1.1. Module GSD file 

Configure the valve terminal modules of the MVT series using a 

GSD file (XML format) for the integration of the MVT valve terminal 

node modules into your system as standard Profinet IOs. You can visit 

the ELCO website to get the latest GSD documents or call the customer 

service line to contact a technician. 

The integration of GSD files into the system depends on the 

configuration software you are using, usually the Siemens Portal 

programming software used by Profinet systems integrates GSD files as 

follows: 

10.1.1.1. Run the Portal software and select "Options>Manage 

general station description files_GSD" in the menu bar. 

 

10.1.1.2. In the next dialog box, select the GSD file you want to 

install and click Install to install it. 

Note: You need to install the latest version of the GSDML file. 
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10.1.1.3. The newly installed MVT valve island node module is 

displayed under “Other field devices> PROFINET-

IO >Gateway > ELCO >MVT”. 

 

10.1.1.4. The user configures the MVT valve terminal node module 

in the Portal according to the actual use. 
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10.1.2. Example of module configuration in the Siemens Portal 

environment 

This section describes how to use the MVT valve island node 

module. In this example, the MVT valve island node module of ELCO is 

used as the Profinet slave station to connect to Siemens PLC-CPU2222C 

through the Profinet bus. By default, all power supply and bus 

connections have been completed. The device name of the MVT valve 

island node module is set to MVT-Gateway. 

The MVT valve terminal node module is configured with the 

following products: 

10.1.2.1. Create a new Portal project. 

Open the TIA Portal software, click “Create new project”, change 

“project name” to MVT, select the save path, and click “Create”. 

 

10.1.2.2. To install the GSD file of Elco MVT series valve terminal 

node products, please refer to the relevant content of "10.1.1 

GSD file" for the specific method. 

10.1.2.3. Double-click "Add New Device" on the left and select the 

PLC model you want to use in the "Controllers" window. 

type description number 

MVT-C-EN Multi-protocol valve terminal node 

slaves 

1 
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10.1.2.4. Double-click the “Device configuration” window on the 

left, and in the “Device view” window, select “Properties>--

PROFINET interface[X2]-->IP protocol”, and set the IP address 

of the PLC. 

 

10.1.2.5. The MVT valve terminal node module is added and 

connected to the PLC for communication. 

1) Double-click “Device configuration” on the left to enter 

the “Network view”, select the MVT-C-EN valve terminal 

node of “Other field devices> PROFINET-IO >Gateway > 

ELCO >MVT" from “Catalog”, and double-click or drag to 



 MVT Valve Terminal Node User Manual                              

 Tianjin Elco Automation Co.,Ltd                                  30 / 

51 
 

add to the network. 

 

2) Click “Not assigned”, click and select “PLC_1.PROFINET 

interface_1”. 

 

3) The MVT-C-EN valve terminal node module is connected to 

the PLC. 
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10.1.2.6. Modify the device name and IP address settings of the 

MVT valve terminal node module. 

1) Click the MVT valve terminal module in “Network view”, 

choose “properties-->PROFINET interface-->Ethernet 

addresses”, set the MVT terminal node module device name, 

MVT-gateway, and IP address in the window. (It should be in 

the same network segment as the IP address of the PLC). 
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2) Select MVT-C-EN, select "Assign device name" from the right-

click menu, click "Update list" on the Assign Profinet device 

name interface, the name and MAC address of the connected 

MVT valve terminal node module will be scanned, select the 

device with the same MAC address and click "Assign name". 
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Tips: In this example, the input address of the MVT valve terminal 

node module is 1-6, and the output address is 1-6, and the input and 

output addresses can be modified as needed. 

 

10.1.2.7. Select “MVT-C-EN, > properties, > Module parameters”. 

 

10.1.2.8. After the parameter setting is completed, the 

configuration is saved and compiled, and the configured 

configuration is downloaded to the PLC to complete the 

configuration work. 

 

10.1.2.9. At this point, if everything is configured correctly, the 

indicators of the MVT valve terminal nodes are all shown in green, 

with the Atc indicator flashing yellow. 
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10.2. Example of Omron PLC configuration 

10.2.1. Module EDS file 

Configure the valve terminal modules of the MVT series using an 

EDS file (EDS format) for integrating the MVT valve terminal node 

modules into your system as standard EtherNet/IP IO. You can visit the 

ELCO website to get the latest EDS documents or call the customer 

service line to contact a technician. 

The integration of EDS files into the system depends on the 

configuration software you are using, using the Sysmac Studio 

programming software from Omron as an example for EtherNet/IP 

systems, and follow the steps below to add EDS files： 

1） Run the Sysmac Studio software and select "Tools>EtherNet/IP 

Connection Settings" in the menu bar. 

 

2） In the “EtherNet/IP Device List”, right-click “Edit”. 
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3） Once the EtherNet/IP port settings appear, right-click on "Display 

EDS Library" in the "Toolbox" on the right. 

 

4） Click "Install" in the "EDS Library", find the EDS file 

corresponding to the valve terminal node, select it, click 

"Open(O)", and the newly installed MVT valve terminal node will 

be displayed in the "ELCO Industry Automation AG > 

Communications Adapter" directory. 
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10.2.2. Example of module configuration in Omron's Sysmac 

Studio environment 

1） Open the Sysmac Studio software, click on "New Project", fill in the 

corresponding information according to the PLC model, and click 

"Create". 

 

2） For the built-in "EtherNet/IP Port Settings" on the PLC, set the "IP 

Address" to the default IP address of the PLC, which is 192.168.250.1 

in this example. 

 
3） To start setting up your EtherNet/IP network, select 

"Tools>EtherNet/IP Connection Settings" in the menu bar. 



 MVT Valve Terminal Node User Manual                              

 Tianjin Elco Automation Co.,Ltd                                  37 / 

51 
 

 
4） Double-click or right-click on the "Edit" PLC's built-in EtherNet/IP 

port settings in the newly opened interface to open the connection 

settings screen. 

 

5） Click the "+" button in the toolbox, fill in the IP address of the module 

you want to configure in the pop-up window (192.168.250.2 in this 

example), select the model MVT-C-EN of the valve terminal node in 

the model name, select the latest revision version, and click the "Add" 

button when you are done. (Note that in order to set the PLC and the 

valve terminal node to the same network segment, the IP address of 

the valve terminal node needs to be set in advance, and the IP 

address can be assigned using the BOOTP-DHCP server tool that 

comes with Rockwell software.) 
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6） Right-click the newly added "Target Device->192.168.250.2 MVT-C-

EN Version 1", follow the situation described in the disconnection 

output control instructions in the pop-up window, select the desired 

type, and click the "OK" button to complete the setting. 

 

7） Since the data from the EtherNet/IP slave is packaged and sent to the 

PLC, it is recommended to create your own data types and global 

variables to facilitate signal reading. The MVT node module occupies 

8_Byte input and 6_Byte output, and the data structure is as follows: 
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type Byte description data length 

input 0~5 Overload detection 48 bit 

6 reserved 8 bit 

7 Mains power state 8 bit 

output 0~5 Valve output control 48 bit 

 

8） According to the above data structure table, establish the structure 

of the data type, and then create the global variables corresponding 

to the module. 

 
Note: When creating a data type, you can ensure that the length 

occupied is the same, and the specific type can be decided according 

to your own habits. For example, if a module occupies 6 byte, you can 

create an array of 48 BOOL, an array of 6 byte, or a variable of 3 Word 

as shown in the figure above. 

9） Establish the global variables corresponding to the MVT node 

module, and divide them into inputs and outputs. Each node module 

needs to correspond to an input and an output of global variables, 

select the data type just created, and select the input and output 

corresponding to the type of "network exposure". 
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The global variables corresponding to similar node modules can 

use the same data type (i.e., structs), that is, the global variables need 

to be created according to the number of node modules used, while 

the structs only need to create one input and one output. If there are 3 

similar MVT nodes in the system, you need to create 6 global variables 

to correspond, but the data type can be the same. 

 
10） In the "Built-in EtherNet/IP Port Settings" window, select "Tag 

Set" and click the "Registration All" button. In the pop-up window, 

register the newly created global variable, then you can see the size 

of the new variable, enter 8 bytes, and output 6 bytes. If the size is 

not, there is a problem with the global variable and data type that 

you just created and needs to be modified. 

 
11）  In the "Built-in EtherNet/IP Port Settings" window, select 

"Connection" on the left, click the "+" button to add a new 
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connection, "Target Device" to select the node module we configure, 

"Connection I/O Type" to Control/Status, "Target Variable" as the 

code input as 101, output as 100, "Originator". Variable" selects the 

new global variable, and "Connection Type" selects Point to Point 

connection. 

 

12） At this point, all the basic settings have been completed, you can 

download the program to the PLC, note that the EtherNet/IP port 

settings need to be downloaded separately, click "Transfer to 

Controller" in the figure above. At this point, if everything is 

configured correctly, the indicators of the MVT valve terminal nodes 

are all shown in green, with the Atc indicator flashing yellow. 
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10.3. Mitsubishi PLC configuration example 

10.3.1. Module CSPP file 

Configure the valve terminal module of the MVT series using a 

CSPP file (CSPP format), which is used to integrate the MVT valve 

terminal node module into your system as a standard CC-Link IE IO. You 

can visit the ELCO company website to get the latest CSPP documents 

or call the customer service line to contact a technician. 

The integration of the CSPP file into the system depends on the 

configuration software you are using, using the Mitsubishi GX-work3 

programming software used in the CC-Link IE system as an example, 

follow these steps to add the CSPP file: 

1) Run the GX-work3 software and select Tool>Profile 

Management(p) >Register(R) in the menu bar. 

 

2) In the next dialog box, select the cspp file you want to install and 

click "Register(R)" to install it. 



 MVT Valve Terminal Node User Manual                              

 Tianjin Elco Automation Co.,Ltd                                  43 / 

51 
 

 

3) The newly installed MVT node modules are displayed in the "Module List> 

CCIEF Basic Module(Tianjin Elco Automation Co, Ltd) > CC-Link IEF Basic Valve 

Controler >MVT-C-EN" hardware directory as follows. 
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10.3.2. Example of module configuration in Mitsubishi GX-

work3 environment 

1） Open the GX-work3 software and click Project>New(N). 

 

2） "Series" to select FX5CPU; Select FX5U for Type; "Program Language" 

is based on your programming habits. Then click "OK". 

 

3） After entering the interface, select the number of "Navigation" items 

on the left, and then select "Parameter>CPU model>Module 

Parameter> and double-click Ethernet Port" to enter the following 

interface. 
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4） IP Address”192.168.250.10”;Subnet Mask”255.255.255.0”. 

 

5） CC-link IEF Basic settings 

（a）CC-link IEF Basic Use with or without "Use". 

 

（b）network configuration settings; Click Detailed setting. 

 

（c）Click "Detect Now>OK". 

 

（d）Change the IP address of the module to 192.168.250.11. 
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（e）Right-click the module and select “Online>Communication 

Setting Reflection of Slave Station”. 

 
（ f ） Right-click the module and choose “Online >Parameter 

Processing of Slave Station”. 

 

（ g ） Click Execute, select "Parameter write", select the desired 

disconnection state in the "safe state" option, and click "Execute". 
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（h）Click on "Close with Reflecting the Setting" 

 

6） Refresh Settings  

（a）Select "Detailed Setting". 

 

（b）The following figure shows the CPU configuration. 

 

（c）Click "CC-Link IEFbasic Settings" > "Apply". 

 

7) Download to PLC, "Online>Write to PLC> parameters + 

program > Execute> all are >OK". 
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Note: After the configuration is completed, the PLC needs to be reset 

or restarted.  
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10.4. Websever debug instance 

1) Turn the DIP switch of the valve terminal node to the IP mode set 

by the webserver (1~2 for Ethernet/IP/5~6 for CCLINK IE), and 

power off and restart the device. 

2) Open Internet Explorer and enter "XX.XX.XX.X (device 

address)/webif/" in the address bar to enter the webserver page. 

 

3) Click on the VALVE ISLAND option, select the point to be forced 

in the Set option, and after clicking the Set button, the 

corresponding point in the Display option will light up. 

 

4) If you need to upgrade the device, you can click Upload>Main-

device>upload page. 
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5) Enter your login and password. 

Account：root，password：password。 

To upgrade, please use the compressed package directly and do 

not need to decompress it. Since it is a multi-protocol upgrade, 

it takes a long time and is expected to take about a minute, so 

please follow the instructions. 

 
6) Click "Choose a firmware file to upload" to upload the required 

upgrade file and click "Send file". 
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